Message ID | 20230712152322.81758-1-quentin@isovalent.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 0a5550b1165cd60ad6972791eda4a3eb7e347280 |
Delegated to: | BPF |
Headers | show |
Series | [bpf-next] bpftool: Use "fallthrough;" keyword instead of comments | expand |
Hello: This patch was applied to bpf/bpf-next.git (master) by Daniel Borkmann <daniel@iogearbox.net>: On Wed, 12 Jul 2023 16:23:22 +0100 you wrote: > After using "__fallthrough;" in a switch/case block in bpftool's > btf_dumper.c [0], and then turning it into a comment [1] to prevent a > merge conflict in linux-next when the keyword was changed into just > "fallthrough;" [2], we can now drop the comment and use the new keyword, > no underscores. > > Also update the other occurrence of "/* fallthrough */" in bpftool. > > [...] Here is the summary with links: - [bpf-next] bpftool: Use "fallthrough;" keyword instead of comments https://git.kernel.org/bpf/bpf-next/c/0a5550b1165c You are awesome, thank you!
diff --git a/tools/bpf/bpftool/btf_dumper.c b/tools/bpf/bpftool/btf_dumper.c index 294de231db99..1b7f69714604 100644 --- a/tools/bpf/bpftool/btf_dumper.c +++ b/tools/bpf/bpftool/btf_dumper.c @@ -835,7 +835,7 @@ static void dotlabel_puts(const char *s) case '|': case ' ': putchar('\\'); - /* fallthrough */ + fallthrough; default: putchar(*s); } diff --git a/tools/bpf/bpftool/feature.c b/tools/bpf/bpftool/feature.c index 0675d6a46413..edda4fc2c4d0 100644 --- a/tools/bpf/bpftool/feature.c +++ b/tools/bpf/bpftool/feature.c @@ -757,7 +757,7 @@ probe_helpers_for_progtype(enum bpf_prog_type prog_type, case BPF_FUNC_probe_write_user: if (!full_mode) continue; - /* fallthrough */ + fallthrough; default: probe_res |= probe_helper_for_progtype(prog_type, supported_type, define_prefix, id, prog_type_str,
After using "__fallthrough;" in a switch/case block in bpftool's btf_dumper.c [0], and then turning it into a comment [1] to prevent a merge conflict in linux-next when the keyword was changed into just "fallthrough;" [2], we can now drop the comment and use the new keyword, no underscores. Also update the other occurrence of "/* fallthrough */" in bpftool. [0] commit 9fd496848b1c ("bpftool: Support inline annotations when dumping the CFG of a program") [1] commit 4b7ef71ac977 ("bpftool: Replace "__fallthrough" by a comment to address merge conflict") [2] commit f7a858bffcdd ("tools: Rename __fallthrough to fallthrough") Signed-off-by: Quentin Monnet <quentin@isovalent.com> --- tools/bpf/bpftool/btf_dumper.c | 2 +- tools/bpf/bpftool/feature.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)