Message ID | 20240513173546.679061-3-admiyo@os.amperecomputing.com (mailing list archive) |
---|---|
State | Changes Requested |
Headers | show |
Series | MCTP over PCC | expand |
On Mon, May 13, 2024 at 01:35:45PM -0400, admiyo@os.amperecomputing.com wrote: > From: Adam Young <admiyo@os.amperecomputing.com> > > Note that this patch sfor code that will be merged > in via ACPICA changes. The corresponding patch in ACPCA > has already merged. > > Signed-off-by: Adam Young <admiyo@os.amperecomputing.com> > --- > drivers/acpi/acpica/rsaddr.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/acpi/acpica/rsaddr.c b/drivers/acpi/acpica/rsaddr.c > index fff48001d7ef..6bd9704f17b0 100644 > --- a/drivers/acpi/acpica/rsaddr.c > +++ b/drivers/acpi/acpica/rsaddr.c > @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource, > > /* Validate the Resource Type */ > > - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) { > + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) { > return (FALSE); More magic numbers. Please add some #defines. Andrew
diff --git a/drivers/acpi/acpica/rsaddr.c b/drivers/acpi/acpica/rsaddr.c index fff48001d7ef..6bd9704f17b0 100644 --- a/drivers/acpi/acpica/rsaddr.c +++ b/drivers/acpi/acpica/rsaddr.c @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource, /* Validate the Resource Type */ - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) { + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) { return (FALSE); }