Message ID | 1485178976-15225-1-git-send-email-pagupta@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Pankaj Gupta <pagupta@redhat.com> wrote: > Change the name of live migration thread from 'migration' > to 'live_migration' to identify it clearly. 'migration' > is a generic word and kernel also has tasks for process > migration with the name 'migration/cpu#'. > > > Signed-off-by: Pankaj Gupta <pagupta@redhat.com> Reviewed-by: Juan Quintela <quintela@redhat.com>
* Pankaj Gupta (pagupta@redhat.com) wrote: > Change the name of live migration thread from 'migration' > to 'live_migration' to identify it clearly. 'migration' > is a generic word and kernel also has tasks for process > migration with the name 'migration/cpu#'. > > > Signed-off-by: Pankaj Gupta <pagupta@redhat.com> > --- > migration/migration.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/migration/migration.c b/migration/migration.c > index f498ab8..6b58976 100644 > --- a/migration/migration.c > +++ b/migration/migration.c > @@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s) > } > > migrate_compress_threads_create(); > - qemu_thread_create(&s->thread, "migration", migration_thread, s, > + qemu_thread_create(&s->thread, "live_migration", migration_thread, s, > QEMU_THREAD_JOINABLE); > s->migration_thread_running = true; > } Yes, that fits; thanks. Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > -- > 2.7.4 > -- Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
On (Mon) 23 Jan 2017 [19:12:56], Pankaj Gupta wrote: > Change the name of live migration thread from 'migration' > to 'live_migration' to identify it clearly. 'migration' > is a generic word and kernel also has tasks for process > migration with the name 'migration/cpu#'. > > > Signed-off-by: Pankaj Gupta <pagupta@redhat.com> Reviewed-by: Amit Shah <amit.shah@redhat.com> Amit
* Pankaj Gupta (pagupta@redhat.com) wrote: > Change the name of live migration thread from 'migration' > to 'live_migration' to identify it clearly. 'migration' > is a generic word and kernel also has tasks for process > migration with the name 'migration/cpu#'. > > > Signed-off-by: Pankaj Gupta <pagupta@redhat.com> Queued. Dave > --- > migration/migration.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/migration/migration.c b/migration/migration.c > index f498ab8..6b58976 100644 > --- a/migration/migration.c > +++ b/migration/migration.c > @@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s) > } > > migrate_compress_threads_create(); > - qemu_thread_create(&s->thread, "migration", migration_thread, s, > + qemu_thread_create(&s->thread, "live_migration", migration_thread, s, > QEMU_THREAD_JOINABLE); > s->migration_thread_running = true; > } > -- > 2.7.4 > > -- Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
diff --git a/migration/migration.c b/migration/migration.c index f498ab8..6b58976 100644 --- a/migration/migration.c +++ b/migration/migration.c @@ -1969,7 +1969,7 @@ void migrate_fd_connect(MigrationState *s) } migrate_compress_threads_create(); - qemu_thread_create(&s->thread, "migration", migration_thread, s, + qemu_thread_create(&s->thread, "live_migration", migration_thread, s, QEMU_THREAD_JOINABLE); s->migration_thread_running = true; }
Change the name of live migration thread from 'migration' to 'live_migration' to identify it clearly. 'migration' is a generic word and kernel also has tasks for process migration with the name 'migration/cpu#'. Signed-off-by: Pankaj Gupta <pagupta@redhat.com> --- migration/migration.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)