Message ID | 1516366207-109842-2-git-send-email-anton.nefedov@virtuozzo.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Fri 19 Jan 2018 01:50:00 PM CET, Anton Nefedov wrote: > Make the stat fields definition slightly more readable. > Cosmetic change only. > > Signed-off-by: Anton Nefedov <anton.nefedov@virtuozzo.com> > --- > qapi/block-core.json | 24 ++++++++++++++++++------ > 1 file changed, 18 insertions(+), 6 deletions(-) > > diff --git a/qapi/block-core.json b/qapi/block-core.json > index e94a688..2e0665e 100644 > --- a/qapi/block-core.json > +++ b/qapi/block-core.json > @@ -733,14 +733,26 @@ > # Since: 0.14.0 > ## > { 'struct': 'BlockDeviceStats', > - 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', 'rd_operations': 'int', > - 'wr_operations': 'int', 'flush_operations': 'int', > + 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', > + > + 'rd_operations': 'int', 'wr_operations': 'int', > + 'flush_operations': 'int', > + > 'flush_total_time_ns': 'int', 'wr_total_time_ns': 'int', > - 'rd_total_time_ns': 'int', 'wr_highest_offset': 'int', > - 'rd_merged': 'int', 'wr_merged': 'int', '*idle_time_ns': 'int', > + 'rd_total_time_ns': 'int', It would be nice to reorder these following the read-write-flush order. This way these would be rd_total_time_ns, wr_total_time_ns and flush_total_time_ns. The order of the fields in the documentation would also need to be changed. Berto
On 6/2/2018 4:12 PM, Alberto Garcia wrote: > On Fri 19 Jan 2018 01:50:00 PM CET, Anton Nefedov wrote: >> Make the stat fields definition slightly more readable. >> Cosmetic change only. >> >> Signed-off-by: Anton Nefedov <anton.nefedov@virtuozzo.com> >> --- >> qapi/block-core.json | 24 ++++++++++++++++++------ >> 1 file changed, 18 insertions(+), 6 deletions(-) >> >> diff --git a/qapi/block-core.json b/qapi/block-core.json >> index e94a688..2e0665e 100644 >> --- a/qapi/block-core.json >> +++ b/qapi/block-core.json >> @@ -733,14 +733,26 @@ >> # Since: 0.14.0 >> ## >> { 'struct': 'BlockDeviceStats', >> - 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', 'rd_operations': 'int', >> - 'wr_operations': 'int', 'flush_operations': 'int', >> + 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', >> + >> + 'rd_operations': 'int', 'wr_operations': 'int', >> + 'flush_operations': 'int', >> + >> 'flush_total_time_ns': 'int', 'wr_total_time_ns': 'int', >> - 'rd_total_time_ns': 'int', 'wr_highest_offset': 'int', >> - 'rd_merged': 'int', 'wr_merged': 'int', '*idle_time_ns': 'int', >> + 'rd_total_time_ns': 'int', > > It would be nice to reorder these following the read-write-flush order. > This way these would be rd_total_time_ns, wr_total_time_ns and > flush_total_time_ns. > > The order of the fields in the documentation would also need to be > changed. > > Berto > Agree, done. I'm also moving here the spelling fixes proposed by Erik.
diff --git a/qapi/block-core.json b/qapi/block-core.json index e94a688..2e0665e 100644 --- a/qapi/block-core.json +++ b/qapi/block-core.json @@ -733,14 +733,26 @@ # Since: 0.14.0 ## { 'struct': 'BlockDeviceStats', - 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', 'rd_operations': 'int', - 'wr_operations': 'int', 'flush_operations': 'int', + 'data': {'rd_bytes': 'int', 'wr_bytes': 'int', + + 'rd_operations': 'int', 'wr_operations': 'int', + 'flush_operations': 'int', + 'flush_total_time_ns': 'int', 'wr_total_time_ns': 'int', - 'rd_total_time_ns': 'int', 'wr_highest_offset': 'int', - 'rd_merged': 'int', 'wr_merged': 'int', '*idle_time_ns': 'int', + 'rd_total_time_ns': 'int', + + 'wr_highest_offset': 'int', + + 'rd_merged': 'int', 'wr_merged': 'int', + + '*idle_time_ns': 'int', + 'failed_rd_operations': 'int', 'failed_wr_operations': 'int', - 'failed_flush_operations': 'int', 'invalid_rd_operations': 'int', - 'invalid_wr_operations': 'int', 'invalid_flush_operations': 'int', + 'failed_flush_operations': 'int', + + 'invalid_rd_operations': 'int', 'invalid_wr_operations': 'int', + 'invalid_flush_operations': 'int', + 'account_invalid': 'bool', 'account_failed': 'bool', 'timed_stats': ['BlockDeviceTimedStats'] } }
Make the stat fields definition slightly more readable. Cosmetic change only. Signed-off-by: Anton Nefedov <anton.nefedov@virtuozzo.com> --- qapi/block-core.json | 24 ++++++++++++++++++------ 1 file changed, 18 insertions(+), 6 deletions(-)