Message ID | 20180125040328.22867-6-tiwei.bie@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h index 2383ded670..3fe99636f3 100644 --- a/include/hw/vfio/vfio-common.h +++ b/include/hw/vfio/vfio-common.h @@ -33,15 +33,6 @@ #define ERR_PREFIX "vfio error: %s: " #define WARN_PREFIX "vfio warning: %s: " -/*#define DEBUG_VFIO*/ -#ifdef DEBUG_VFIO -#define DPRINTF(fmt, ...) \ - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) -#else -#define DPRINTF(fmt, ...) \ - do { } while (0) -#endif - enum { VFIO_DEVICE_TYPE_PCI = 0, VFIO_DEVICE_TYPE_PLATFORM = 1,
This macro isn't used by any VFIO code. And its name is too generic. The vfio-common.h (in include/hw/vfio) can be included by other modules in QEMU. It can introduce conflicts. Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> --- include/hw/vfio/vfio-common.h | 9 --------- 1 file changed, 9 deletions(-)