Message ID | 20181004161852.11673-2-crosa@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Trivial fixes and clean ups | expand |
On 10/4/18 11:18 AM, Cleber Rosa wrote: > A trivial comment typo fix. > > Signed-off-by: Cleber Rosa <crosa@redhat.com> > --- > qemu-img.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/qemu-img.c b/qemu-img.c > index b12f4cd19b..a96b76c187 100644 > --- a/qemu-img.c > +++ b/qemu-img.c > @@ -1085,7 +1085,7 @@ static int64_t find_nonzero(const uint8_t *buf, int64_t n) > } > > /* > - * Returns true iff the first sector pointed to by 'buf' contains at least > + * Returns true if the first sector pointed to by 'buf' contains at least NACK. You're not the first person to propose this change. However, "iff" is an English word (albeit archaic) which is shorthand for "if and only if", which has a distinct logical meaning separate from the weaker "if". Spelling it out in longhand instead of calling it a typo is probably acceptable, though. > * a non-NUL byte. > * > * 'pnum' is set to the number of sectors (including and immediately following >
On 10/4/18 12:48 PM, Eric Blake wrote: > On 10/4/18 11:18 AM, Cleber Rosa wrote: >> A trivial comment typo fix. >> >> Signed-off-by: Cleber Rosa <crosa@redhat.com> >> --- >> qemu-img.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/qemu-img.c b/qemu-img.c >> index b12f4cd19b..a96b76c187 100644 >> --- a/qemu-img.c >> +++ b/qemu-img.c >> @@ -1085,7 +1085,7 @@ static int64_t find_nonzero(const uint8_t *buf, >> int64_t n) >> } >> /* >> - * Returns true iff the first sector pointed to by 'buf' contains at >> least >> + * Returns true if the first sector pointed to by 'buf' contains at >> least > > NACK. You're not the first person to propose this change. However, > "iff" is an English word (albeit archaic) which is shorthand for "if and > only if", which has a distinct logical meaning separate from the weaker > "if". Spelling it out in longhand instead of calling it a typo is > probably acceptable, though. > Wow, thanks for the explanation. I agree that spelling it out is a good option, as it'll probably prevent other people from falling into the same "language trap" as I did. Thanks! - Cleber.
On 04/10/2018 18:53, Cleber Rosa wrote:> On 10/4/18 12:48 PM, Eric Blake wrote: >> On 10/4/18 11:18 AM, Cleber Rosa wrote: >>> A trivial comment typo fix. >>> >>> Signed-off-by: Cleber Rosa <crosa@redhat.com> >>> --- >>> qemu-img.c | 2 +- >>> 1 file changed, 1 insertion(+), 1 deletion(-) >>> >>> diff --git a/qemu-img.c b/qemu-img.c >>> index b12f4cd19b..a96b76c187 100644 >>> --- a/qemu-img.c >>> +++ b/qemu-img.c >>> @@ -1085,7 +1085,7 @@ static int64_t find_nonzero(const uint8_t *buf, >>> int64_t n) >>> } >>> /* >>> - * Returns true iff the first sector pointed to by 'buf' contains at >>> least >>> + * Returns true if the first sector pointed to by 'buf' contains at >>> least >> >> NACK. You're not the first person to propose this change. However, >> "iff" is an English word (albeit archaic) which is shorthand for "if and >> only if", which has a distinct logical meaning separate from the weaker >> "if". Spelling it out in longhand instead of calling it a typo is >> probably acceptable, though. >> > > Wow, thanks for the explanation. I agree that spelling it out is a good > option, as it'll probably prevent other people from falling into the > same "language trap" as I did. https://lists.gnu.org/archive/html/qemu-devel/2011-06/msg01269.html https://lists.gnu.org/archive/html/qemu-devel/2017-04/msg04200.html ;)
On 4 October 2018 at 17:48, Eric Blake <eblake@redhat.com> wrote: > On 10/4/18 11:18 AM, Cleber Rosa wrote: >> >> A trivial comment typo fix. >> >> Signed-off-by: Cleber Rosa <crosa@redhat.com> >> --- a/qemu-img.c >> +++ b/qemu-img.c >> @@ -1085,7 +1085,7 @@ static int64_t find_nonzero(const uint8_t *buf, >> int64_t n) >> } >> /* >> - * Returns true iff the first sector pointed to by 'buf' contains at >> least >> + * Returns true if the first sector pointed to by 'buf' contains at least > > > NACK. You're not the first person to propose this change. However, "iff" > is an English word (albeit archaic) which is shorthand for "if and only if", > which has a distinct logical meaning separate from the weaker "if". > Spelling it out in longhand instead of calling it a typo is probably > acceptable, though. Yes; if you happen to have a mathematical background then it's a familiar abbreviation; but otherwise it isn't, and it's more confusing than helpful I think. (I don't think it's archaic; it's just commonly used in university-and-higher-level maths and not elsewhere.) git grep '\Wiff\W' shows a surprisingly large number of uses. (NB that some of those are in 3rd-party code, notably the libdecnumber stuff, and should probably not be changed.) thanks -- PMM
diff --git a/qemu-img.c b/qemu-img.c index b12f4cd19b..a96b76c187 100644 --- a/qemu-img.c +++ b/qemu-img.c @@ -1085,7 +1085,7 @@ static int64_t find_nonzero(const uint8_t *buf, int64_t n) } /* - * Returns true iff the first sector pointed to by 'buf' contains at least + * Returns true if the first sector pointed to by 'buf' contains at least * a non-NUL byte. * * 'pnum' is set to the number of sectors (including and immediately following
A trivial comment typo fix. Signed-off-by: Cleber Rosa <crosa@redhat.com> --- qemu-img.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)