diff mbox series

[34/36] next-cube: rename old_scr2 and scr2_2 in next_scr2_rtc_update()

Message ID 20241023085852.1061031-35-mark.cave-ayland@ilande.co.uk (mailing list archive)
State New
Headers show
Series next-cube: more tidy-ups and improvements | expand

Commit Message

Mark Cave-Ayland Oct. 23, 2024, 8:58 a.m. UTC
Rename them to old_scr2_rtc and scr2_rtc to reflect that they contain the previous
and current values of the SCR2 RTC bits.

Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
---
 hw/m68k/next-cube.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

Thomas Huth Nov. 9, 2024, 8:25 a.m. UTC | #1
Am Wed, 23 Oct 2024 09:58:50 +0100
schrieb Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>:

> Rename them to old_scr2_rtc and scr2_rtc to reflect that they contain the previous
> and current values of the SCR2 RTC bits.
> 
> Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
> ---
>  hw/m68k/next-cube.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/hw/m68k/next-cube.c b/hw/m68k/next-cube.c
> index 076c9d1f3a..ece63f20b1 100644
> --- a/hw/m68k/next-cube.c
> +++ b/hw/m68k/next-cube.c
> @@ -177,17 +177,17 @@ static void next_scr2_led_update(NeXTPC *s)
>  
>  static void next_scr2_rtc_update(NeXTPC *s)
>  {
> -    uint8_t old_scr2, scr2_2;
> +    uint8_t old_scr2_rtc, scr2_rtc;
>  
> -    old_scr2 = extract32(s->old_scr2, 8, 8);
> -    scr2_2 = extract32(s->scr2, 8, 8);
> +    old_scr2_rtc = extract32(s->old_scr2, 8, 8);
> +    scr2_rtc = extract32(s->scr2, 8, 8);
>  
> -    if (scr2_2 & 0x1) {
> +    if (scr2_rtc & 0x1) {
>          /* DPRINTF("RTC %x phase %i\n", scr2_2, rtc->phase); */
>          /* If we are in going down clock... do something */
> -        if (((old_scr2 & SCR2_RTCLK) != (scr2_2 & SCR2_RTCLK)) &&
> -                ((scr2_2 & SCR2_RTCLK) == 0)) {
> -            if (scr2_2 & SCR2_RTDATA) {
> +        if (((old_scr2_rtc & SCR2_RTCLK) != (scr2_rtc & SCR2_RTCLK)) &&
> +                ((scr2_rtc & SCR2_RTCLK) == 0)) {
> +            if (scr2_rtc & SCR2_RTDATA) {
>                  qemu_irq_raise(s->rtc_data_irq);
>              } else {
>                  qemu_irq_lower(s->rtc_data_irq);

Reviewed-by: Thomas Huth <huth@tuxfamily.org>
diff mbox series

Patch

diff --git a/hw/m68k/next-cube.c b/hw/m68k/next-cube.c
index 076c9d1f3a..ece63f20b1 100644
--- a/hw/m68k/next-cube.c
+++ b/hw/m68k/next-cube.c
@@ -177,17 +177,17 @@  static void next_scr2_led_update(NeXTPC *s)
 
 static void next_scr2_rtc_update(NeXTPC *s)
 {
-    uint8_t old_scr2, scr2_2;
+    uint8_t old_scr2_rtc, scr2_rtc;
 
-    old_scr2 = extract32(s->old_scr2, 8, 8);
-    scr2_2 = extract32(s->scr2, 8, 8);
+    old_scr2_rtc = extract32(s->old_scr2, 8, 8);
+    scr2_rtc = extract32(s->scr2, 8, 8);
 
-    if (scr2_2 & 0x1) {
+    if (scr2_rtc & 0x1) {
         /* DPRINTF("RTC %x phase %i\n", scr2_2, rtc->phase); */
         /* If we are in going down clock... do something */
-        if (((old_scr2 & SCR2_RTCLK) != (scr2_2 & SCR2_RTCLK)) &&
-                ((scr2_2 & SCR2_RTCLK) == 0)) {
-            if (scr2_2 & SCR2_RTDATA) {
+        if (((old_scr2_rtc & SCR2_RTCLK) != (scr2_rtc & SCR2_RTCLK)) &&
+                ((scr2_rtc & SCR2_RTCLK) == 0)) {
+            if (scr2_rtc & SCR2_RTDATA) {
                 qemu_irq_raise(s->rtc_data_irq);
             } else {
                 qemu_irq_lower(s->rtc_data_irq);