diff mbox

restorecond: Fix consistancy of DESTDIR usage

Message ID 20180529072904.26084-1-bigon@debian.org (mailing list archive)
State Not Applicable
Headers show

Commit Message

Laurent Bigonville May 29, 2018, 7:29 a.m. UTC
From: Laurent Bigonville <bigon@bigon.be>

---
 restorecond/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Nicolas Iooss May 30, 2018, 8:19 p.m. UTC | #1
On Tue, May 29, 2018 at 9:29 AM, Laurent Bigonville <bigon@debian.org> wrote:
> From: Laurent Bigonville <bigon@bigon.be>
>
> ---
>  restorecond/Makefile | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/restorecond/Makefile b/restorecond/Makefile
> index 25be18d4..fed65bba 100644
> --- a/restorecond/Makefile
> +++ b/restorecond/Makefile
> @@ -9,7 +9,7 @@ DBUSSERVICEDIR = $(PREFIX)/share/dbus-1/services
>  SYSTEMDDIR ?= $(PREFIX)/lib/systemd
>
>  autostart_DATA = sealertauto.desktop
> -INITDIR ?= $(DESTDIR)/etc/rc.d/init.d
> +INITDIR ?= /etc/rc.d/init.d
>  SELINUXDIR = $(DESTDIR)/etc/selinux

This looks good to me, but seeing the SELINUXDIR definition, I am
wondering whether this line should also be migrated to remove DESTDIR
from it. This could be done in an other patch.

Nicolas

>
>  DBUSFLAGS = -DHAVE_DBUS $(shell $(PKG_CONFIG) --cflags dbus-glib-1)
> @@ -42,8 +42,8 @@ install: all
>         -mkdir -p $(DESTDIR)$(SBINDIR)
>         install -m 755 restorecond $(DESTDIR)$(SBINDIR)
>         install -m 644 restorecond.8 $(DESTDIR)$(MANDIR)/man8
> -       -mkdir -p $(INITDIR)
> -       install -m 755 restorecond.init $(INITDIR)/restorecond
> +       -mkdir -p $(DESTDIR)$(INITDIR)
> +       install -m 755 restorecond.init $(DESTDIR)$(INITDIR)/restorecond
>         -mkdir -p $(SELINUXDIR)
>         install -m 644 restorecond.conf $(SELINUXDIR)/restorecond.conf
>         install -m 644 restorecond_user.conf $(SELINUXDIR)/restorecond_user.conf
> --
> 2.17.0
Laurent Bigonville May 31, 2018, 10:47 a.m. UTC | #2
Le 30/05/18 à 22:19, Nicolas Iooss a écrit :
> On Tue, May 29, 2018 at 9:29 AM, Laurent Bigonville <bigon@debian.org> wrote:
>> From: Laurent Bigonville <bigon@bigon.be>
>>
>> ---
>>   restorecond/Makefile | 6 +++---
>>   1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/restorecond/Makefile b/restorecond/Makefile
>> index 25be18d4..fed65bba 100644
>> --- a/restorecond/Makefile
>> +++ b/restorecond/Makefile
>> @@ -9,7 +9,7 @@ DBUSSERVICEDIR = $(PREFIX)/share/dbus-1/services
>>   SYSTEMDDIR ?= $(PREFIX)/lib/systemd
>>
>>   autostart_DATA = sealertauto.desktop
>> -INITDIR ?= $(DESTDIR)/etc/rc.d/init.d
>> +INITDIR ?= /etc/rc.d/init.d
>>   SELINUXDIR = $(DESTDIR)/etc/selinux
> This looks good to me, but seeing the SELINUXDIR definition, I am
> wondering whether this line should also be migrated to remove DESTDIR
> from it. This could be done in an other patch.

You want a new patch? I could amend that one instead
>
> Nicolas
>
>>   DBUSFLAGS = -DHAVE_DBUS $(shell $(PKG_CONFIG) --cflags dbus-glib-1)
>> @@ -42,8 +42,8 @@ install: all
>>          -mkdir -p $(DESTDIR)$(SBINDIR)
>>          install -m 755 restorecond $(DESTDIR)$(SBINDIR)
>>          install -m 644 restorecond.8 $(DESTDIR)$(MANDIR)/man8
>> -       -mkdir -p $(INITDIR)
>> -       install -m 755 restorecond.init $(INITDIR)/restorecond
>> +       -mkdir -p $(DESTDIR)$(INITDIR)
>> +       install -m 755 restorecond.init $(DESTDIR)$(INITDIR)/restorecond
>>          -mkdir -p $(SELINUXDIR)
>>          install -m 644 restorecond.conf $(SELINUXDIR)/restorecond.conf
>>          install -m 644 restorecond_user.conf $(SELINUXDIR)/restorecond_user.conf
>> --
>> 2.17.0
diff mbox

Patch

diff --git a/restorecond/Makefile b/restorecond/Makefile
index 25be18d4..fed65bba 100644
--- a/restorecond/Makefile
+++ b/restorecond/Makefile
@@ -9,7 +9,7 @@  DBUSSERVICEDIR = $(PREFIX)/share/dbus-1/services
 SYSTEMDDIR ?= $(PREFIX)/lib/systemd
 
 autostart_DATA = sealertauto.desktop
-INITDIR ?= $(DESTDIR)/etc/rc.d/init.d
+INITDIR ?= /etc/rc.d/init.d
 SELINUXDIR = $(DESTDIR)/etc/selinux
 
 DBUSFLAGS = -DHAVE_DBUS $(shell $(PKG_CONFIG) --cflags dbus-glib-1)
@@ -42,8 +42,8 @@  install: all
 	-mkdir -p $(DESTDIR)$(SBINDIR)
 	install -m 755 restorecond $(DESTDIR)$(SBINDIR)
 	install -m 644 restorecond.8 $(DESTDIR)$(MANDIR)/man8
-	-mkdir -p $(INITDIR)
-	install -m 755 restorecond.init $(INITDIR)/restorecond
+	-mkdir -p $(DESTDIR)$(INITDIR)
+	install -m 755 restorecond.init $(DESTDIR)$(INITDIR)/restorecond
 	-mkdir -p $(SELINUXDIR)
 	install -m 644 restorecond.conf $(SELINUXDIR)/restorecond.conf
 	install -m 644 restorecond_user.conf $(SELINUXDIR)/restorecond_user.conf