Message ID | 1389510152.13361.4.camel@phoenix (mailing list archive) |
---|---|
State | Accepted |
Commit | 5a33d30ff1b8fdfb5bd8f4fa46dd473bf768aeff |
Headers | show |
On Sunday 12 January 2014 12:32 PM, Axel Lin wrote: > The driver name in current code looks like a compatible string which is not > the naming convention for platform drivers. > Fix it and also add modalias since this driver can be built as a module. > > Signed-off-by: Axel Lin<axel.lin@ingics.com> > --- > drivers/spi/spi-ti-qspi.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/drivers/spi/spi-ti-qspi.c b/drivers/spi/spi-ti-qspi.c > index 2a1ab49..3d09265 100644 > --- a/drivers/spi/spi-ti-qspi.c > +++ b/drivers/spi/spi-ti-qspi.c > @@ -567,7 +567,7 @@ static struct platform_driver ti_qspi_driver = { > .probe = ti_qspi_probe, > .remove = ti_qspi_remove, > .driver = { > - .name = "ti,dra7xxx-qspi", > + .name = "ti-qspi", > .owner = THIS_MODULE, > .pm =&ti_qspi_pm_ops, > .of_match_table = ti_qspi_match, > @@ -579,3 +579,4 @@ module_platform_driver(ti_qspi_driver); > MODULE_AUTHOR("Sourav Poddar<sourav.poddar@ti.com>"); > MODULE_LICENSE("GPL v2"); > MODULE_DESCRIPTION("TI QSPI controller driver"); > +MODULE_ALIAS("platform:ti-qspi"); Acked-by: Sourav Poddar <sourav.poddar@ti.com> -- To unsubscribe from this list: send the line "unsubscribe linux-spi" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Sun, Jan 12, 2014 at 03:02:32PM +0800, Axel Lin wrote: > The driver name in current code looks like a compatible string which is not > the naming convention for platform drivers. > Fix it and also add modalias since this driver can be built as a module. Applied, thanks.
diff --git a/drivers/spi/spi-ti-qspi.c b/drivers/spi/spi-ti-qspi.c index 2a1ab49..3d09265 100644 --- a/drivers/spi/spi-ti-qspi.c +++ b/drivers/spi/spi-ti-qspi.c @@ -567,7 +567,7 @@ static struct platform_driver ti_qspi_driver = { .probe = ti_qspi_probe, .remove = ti_qspi_remove, .driver = { - .name = "ti,dra7xxx-qspi", + .name = "ti-qspi", .owner = THIS_MODULE, .pm = &ti_qspi_pm_ops, .of_match_table = ti_qspi_match, @@ -579,3 +579,4 @@ module_platform_driver(ti_qspi_driver); MODULE_AUTHOR("Sourav Poddar <sourav.poddar@ti.com>"); MODULE_LICENSE("GPL v2"); MODULE_DESCRIPTION("TI QSPI controller driver"); +MODULE_ALIAS("platform:ti-qspi");
The driver name in current code looks like a compatible string which is not the naming convention for platform drivers. Fix it and also add modalias since this driver can be built as a module. Signed-off-by: Axel Lin <axel.lin@ingics.com> --- drivers/spi/spi-ti-qspi.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)