Message ID | 20200102133822.29346-4-geert+renesas@glider.be (mailing list archive) |
---|---|
State | Accepted |
Commit | 1bec84ddd85ae7a2b1df5fef3a5c7e5c44cbe36e |
Headers | show |
Series | spi: rspi: Add support for multiple native and GPIO chip selects | expand |
diff --git a/drivers/spi/spi-rspi.c b/drivers/spi/spi-rspi.c index 74a12f4dee849125..e54a25f848ea38c7 100644 --- a/drivers/spi/spi-rspi.c +++ b/drivers/spi/spi-rspi.c @@ -620,9 +620,8 @@ static int rspi_dma_transfer(struct rspi_data *rspi, struct sg_table *tx, dmaengine_terminate_all(rspi->ctlr->dma_rx); no_dma_rx: if (ret == -EAGAIN) { - pr_warn_once("%s %s: DMA not available, falling back to PIO\n", - dev_driver_string(&rspi->ctlr->dev), - dev_name(&rspi->ctlr->dev)); + dev_warn_once(&rspi->ctlr->dev, + "DMA not available, falling back to PIO\n"); } return ret; }
Use the helper introduced by commit e135303bd5bebcd2 ("device: Add dev_<level>_once variants") instead of open-coding the same operation. Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be> --- drivers/spi/spi-rspi.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-)