Message ID | 20240205-cdns-qspi-pm-fix-v2-1-2e7bbad49a46@bootlin.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | spi: cadence-qspi: Fix runtime PM and system-wide suspend | expand |
On Feb 05, 2024 at 15:57:29 +0100, Théo Lebrun wrote: > Follow kernel naming convention with regards to power-management > callback function names. > > The convention in the kernel is: > - prefix_suspend means the system-wide suspend callback; > - prefix_runtime_suspend means the runtime PM suspend callback. > The same applies to resume callbacks. > > Fixes: 0578a6dbfe75 ("spi: spi-cadence-quadspi: add runtime pm support") Not sure if it's a bug as such since there's no functional change other than renaming. > Signed-off-by: Théo Lebrun <theo.lebrun@bootlin.com> > --- > drivers/spi/spi-cadence-quadspi.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/spi/spi-cadence-quadspi.c b/drivers/spi/spi-cadence-quadspi.c > index 74647dfcb86c..720b28d2980c 100644 > --- a/drivers/spi/spi-cadence-quadspi.c > +++ b/drivers/spi/spi-cadence-quadspi.c > @@ -1927,7 +1927,7 @@ static void cqspi_remove(struct platform_device *pdev) > pm_runtime_disable(&pdev->dev); > } > > -static int cqspi_suspend(struct device *dev) > +static int cqspi_runtime_suspend(struct device *dev) > { > struct cqspi_st *cqspi = dev_get_drvdata(dev); > struct spi_controller *host = dev_get_drvdata(dev); > @@ -1941,7 +1941,7 @@ static int cqspi_suspend(struct device *dev) > return ret; > } > > -static int cqspi_resume(struct device *dev) > +static int cqspi_runtime_resume(struct device *dev) > { > struct cqspi_st *cqspi = dev_get_drvdata(dev); > struct spi_controller *host = dev_get_drvdata(dev); > @@ -1956,8 +1956,8 @@ static int cqspi_resume(struct device *dev) > return spi_controller_resume(host); > } > > -static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_suspend, > - cqspi_resume, NULL); > +static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_runtime_suspend, > + cqspi_runtime_resume, NULL); > No objections as such, Reviewed-by: Dhruva Gole <d-gole@ti.com>
Hello, On Wed Feb 7, 2024 at 9:33 AM CET, Dhruva Gole wrote: > On Feb 05, 2024 at 15:57:29 +0100, Théo Lebrun wrote: > > Follow kernel naming convention with regards to power-management > > callback function names. > > > > The convention in the kernel is: > > - prefix_suspend means the system-wide suspend callback; > > - prefix_runtime_suspend means the runtime PM suspend callback. > > The same applies to resume callbacks. > > > > Fixes: 0578a6dbfe75 ("spi: spi-cadence-quadspi: add runtime pm support") > > Not sure if it's a bug as such since there's no functional change other > than renaming. I see where you come from. I'll fix it when/if there is a second revision. [...] > No objections as such, > Reviewed-by: Dhruva Gole <d-gole@ti.com> Thanks! -- Théo Lebrun, Bootlin Embedded Linux and Kernel engineering https://bootlin.com
diff --git a/drivers/spi/spi-cadence-quadspi.c b/drivers/spi/spi-cadence-quadspi.c index 74647dfcb86c..720b28d2980c 100644 --- a/drivers/spi/spi-cadence-quadspi.c +++ b/drivers/spi/spi-cadence-quadspi.c @@ -1927,7 +1927,7 @@ static void cqspi_remove(struct platform_device *pdev) pm_runtime_disable(&pdev->dev); } -static int cqspi_suspend(struct device *dev) +static int cqspi_runtime_suspend(struct device *dev) { struct cqspi_st *cqspi = dev_get_drvdata(dev); struct spi_controller *host = dev_get_drvdata(dev); @@ -1941,7 +1941,7 @@ static int cqspi_suspend(struct device *dev) return ret; } -static int cqspi_resume(struct device *dev) +static int cqspi_runtime_resume(struct device *dev) { struct cqspi_st *cqspi = dev_get_drvdata(dev); struct spi_controller *host = dev_get_drvdata(dev); @@ -1956,8 +1956,8 @@ static int cqspi_resume(struct device *dev) return spi_controller_resume(host); } -static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_suspend, - cqspi_resume, NULL); +static DEFINE_RUNTIME_DEV_PM_OPS(cqspi_dev_pm_ops, cqspi_runtime_suspend, + cqspi_runtime_resume, NULL); static const struct cqspi_driver_platdata cdns_qspi = { .quirks = CQSPI_DISABLE_DAC_MODE,
Follow kernel naming convention with regards to power-management callback function names. The convention in the kernel is: - prefix_suspend means the system-wide suspend callback; - prefix_runtime_suspend means the runtime PM suspend callback. The same applies to resume callbacks. Fixes: 0578a6dbfe75 ("spi: spi-cadence-quadspi: add runtime pm support") Signed-off-by: Théo Lebrun <theo.lebrun@bootlin.com> --- drivers/spi/spi-cadence-quadspi.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)