Message ID | 20200707165037.1026246-1-armbru@redhat.com (mailing list archive) |
---|---|
Headers | show |
Series | error: auto propagated local_err part I | expand |
07.07.2020 19:50, Markus Armbruster wrote: > To speed things up, I'm taking the liberty to respin Vladimir's series > with my documentation amendments. Thank you! > > After my documentation work, I'm very much inclined to rename > ERRP_AUTO_PROPAGATE() to ERRP_GUARD(). The fact that it propagates > below the hood is detail. What matters to its users is that it lets > them use @errp more freely. Thoughts? No objections, if we are making error-propagation to be internal implementation detail, no reason to shout about it in the macro name.
On 7/7/20 11:50 AM, Markus Armbruster wrote: > To speed things up, I'm taking the liberty to respin Vladimir's series > with my documentation amendments. > > After my documentation work, I'm very much inclined to rename > ERRP_AUTO_PROPAGATE() to ERRP_GUARD(). The fact that it propagates > below the hood is detail. What matters to its users is that it lets > them use @errp more freely. Thoughts? I like it - the shorter name is easier to type. (The rename is a mechanical change, so if we agree to it, we should do it up front to minimize the churn to all the functions where we add use of the macro) > > Based-on: Message-Id: <20200707160613.848843-1-armbru@redhat.com> > > Available from my public repository https://repo.or.cz/qemu/armbru.git > on branch error-auto. > > v12: (based on "[PATCH v4 00/45] Less clumsy error checking") > 01: Comments merged properly with recent commit "error: Document Error > API usage rules", and edited for clarity. Put ERRP_AUTO_PROPAGATE() > before its helpers, and touch up style. > 01-08: Commit messages tweaked >