mbox series

[0/3] x86/irq: cleanup use of open-coded values

Message ID 20250315010033.2917197-1-dmukhin@ford.com (mailing list archive)
Headers show
Series x86/irq: cleanup use of open-coded values | expand

Message

Denis Mukhin March 15, 2025, 1 a.m. UTC
Remove uses of open-coded value 16 in x86's interrupt management code
to enhance readability.
  
Patch 0 makes a cosmetic rename NR_ISAIRQS -> NR_ISA_IRQS as per
code review [1].

Patch 1 makes use of NR_ISA_IRQS in the code where necessary.
 
Patch 2 adds new symbol APIC_VECTOR_VALID and makes use of it.
 
No functional changes.
 
[1]: https://lore.kernel.org/xen-devel/20250314011528.2608217-1-dmukhin@ford.com/

Denis Mukhin (3):
  x86/irq: rename NR_ISAIRQS to NR_ISA_IRQS
  x86/irq: use NR_ISA_IRQS instead of open-coded value
  x86/irq: introduce APIC_VECTOR_VALID

 xen/arch/x86/cpu/mcheck/mce_intel.c |  2 +-
 xen/arch/x86/hvm/dm.c               |  2 +-
 xen/arch/x86/hvm/hvm.c              |  4 ++--
 xen/arch/x86/hvm/irq.c              | 17 +++++++++--------
 xen/arch/x86/hvm/vlapic.c           | 10 +++++-----
 xen/arch/x86/hvm/vpic.c             |  4 ++--
 xen/arch/x86/hvm/vpt.c              |  2 +-
 xen/arch/x86/include/asm/apicdef.h  |  1 +
 xen/arch/x86/include/asm/hvm/irq.h  |  4 ++--
 xen/arch/x86/include/asm/irq.h      |  2 +-
 xen/arch/x86/io_apic.c              | 12 ++++++------
 xen/arch/x86/irq.c                  |  6 +++---
 xen/arch/x86/physdev.c              |  2 +-
 xen/drivers/passthrough/x86/hvm.c   |  4 ++--
 14 files changed, 37 insertions(+), 35 deletions(-)