@@ -694,10 +694,106 @@ static int insert_val_into_array(uint32_t val[],
return 0;
}
+static int compare_val(const uint32_t val[],
+ const struct feat_node *feat,
+ const struct feat_props *props,
+ unsigned int cos)
+{
+ unsigned int i;
+
+ for ( i = 0; i < props->cos_num; i++ )
+ {
+ uint32_t feat_val;
+
+ /* If cos is bigger than cos_max, we need compare default value. */
+ if ( cos > feat->cos_max )
+ {
+ /*
+ * COS ID 0 always stores the default value.
+ * For CDP:
+ * - DATA default value stored in cos_reg_val[0];
+ * - CODE default value stored in cos_reg_val[1].
+ */
+ feat_val = feat->cos_reg_val[i];
+
+ /*
+ * If cos is bigger than feature's cos_max, the val should be
+ * default value. Otherwise, it fails to find a COS ID. So we
+ * have to exit find flow.
+ */
+ if ( val[i] != feat_val )
+ return -EINVAL;
+ }
+ else
+ {
+ feat_val = feat->cos_reg_val[cos * props->cos_num + i];
+ if ( val[i] != feat_val )
+ return 0;
+ }
+ }
+
+ return 1;
+}
+
static int find_cos(const uint32_t val[], unsigned int array_len,
enum psr_feat_type feat_type,
const struct psr_socket_info *info)
{
+ unsigned int cos, i;
+ const unsigned int *ref = info->cos_ref;
+ const struct feat_node *feat;
+ unsigned int cos_max;
+
+ /* cos_max is the one of the feature which is being set. */
+ feat = info->features[feat_type];
+ if ( !feat )
+ return -ENOENT;
+
+ cos_max = feat->cos_max;
+
+ for ( cos = 0; cos <= cos_max; cos++ )
+ {
+ const uint32_t *val_ptr = val;
+ unsigned int len = array_len;
+ int rc = 0;
+
+ if ( cos && !ref[cos] )
+ continue;
+
+ for ( i = 0; i < PSR_SOCKET_FEAT_NUM; i++ )
+ {
+ const struct feat_props *props = feat_props[i];
+
+ feat = info->features[i];
+ if ( !feat || !props )
+ continue;
+
+ if ( len < props->cos_num )
+ return -ENOSPC;
+
+ /*
+ * Compare value according to feature array order.
+ * We must follow this order because value array is assembled
+ * as this order.
+ */
+ rc = compare_val(val_ptr, feat, props, cos);
+ if ( rc < 0 )
+ return rc;
+
+ /* If fail to match, go to next cos to compare. */
+ if ( !rc )
+ break;
+
+ len -= props->cos_num;
+
+ val_ptr += props->cos_num;
+ }
+
+ /* For this COS ID all entries in the values array do match. Use it. */
+ if ( rc )
+ return cos;
+ }
+
return -ENOENT;
}
Continue from patch: 'x86: refactor psr: L3 CAT: set value: assemble features value array' We can try to find if there is a COS ID on which all features' COS registers values are same as the array assembled before. Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com> --- v11: - move 'compare_val' implementation from CDP patch to this. (suggested by Jan Beulich) - remove 'rc' in 'compare_val' to make codes clearer. (suggested by Jan Beulich) - changes about 'feat_props'. (suggested by Jan Beulich) - fix bug. (suggested by Jan Beulich) - remove unnecessary variable initialization. (suggested by Jan Beulich) - remove unnecessary comment. (suggested by Jan Beulich) - adjust array check place prior to using the array. (suggested by Jan Beulich) - add comment. v10: - remove 'compare_val' hook and its CAT implementation. Make its functionality be generic in 'find_cos' flow. (suggested by Jan Beulich) - changes related to 'props'. (suggested by Jan Beulich) - rename 'val_array' to 'val_ptr'. (suggested by Jan Beulich) - rename 'find' to 'found'. (suggested by Jan Beulich) - move some variables declaration and initialization into loop. (suggested by Jan Beulich) - adjust codes positions. (suggested by Jan Beulich) v9: - modify comments of 'compare_val' to be same as current implementation. (suggested by Wei Liu) - fix indentation issue. (suggested by Wei Liu) - rename 'l3_cat_compare_val' to 'cat_compare_val' to cover all L3/L2 CAT features. (suggested by Roger Pau) - remove parameter 'found' from 'cat_compare_val' and modify the return values to let caller know if the id is found or not. (suggested by Roger Pau) - replace feature list handling to feature array handling. (suggested by Roger Pau) - replace 'get_cos_num' to 'feat->cos_num'. (suggested by Jan Beulich) - directly use 'cos_reg_val[0]' as default value. (suggested by Jan Beulich) - modify patch title to indicate 'L3 CAT'. (suggested by Jan Beulich) - changes about 'uint64_t' to 'uint32_t'. (suggested by Jan Beulich) v5: - modify commit message to provide exact patch name to continue from. (suggested by Jan Beulich) - remove 'get_cos_max_from_type' because it can be replaced by 'get_cos_max'. - move type check out from callback functions to caller. (suggested by Jan Beulich) - modify variables names to make them better, e.g. 'feat_tmp' to 'feat'. (suggested by Jan Beulich) - modify comments according to changes of codes. (suggested by Jan Beulich) v4: - create this patch to make codes easier to understand. (suggested by Jan Beulich) --- xen/arch/x86/psr.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 96 insertions(+)