Message ID | 20191121181300.6497-3-al1img@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Remove backend xen store entry on domain destroy | expand |
Oleksandr Grytsov writes ("[PATCH v2 2/3] libxl: rename VKB backend type "linux" to "pv""): > From: Oleksandr Grytsov <oleksandr_grytsov@epam.com> > > There are two kind of VKB backends: QEMU and user space PV backend. > For PV backend "linux" enum is used but this name is confused. Rename > "linux" enum to "pv" as it better matches user space PV backend. > > Signed-off-by: Oleksandr Grytsov <oleksandr_grytsov@epam.com> Requested-by: Ian Jackson <ian.jackson@eu.citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Thanks. Ian.
On Fri, Nov 22, 2019 at 11:14:41AM +0000, Ian Jackson wrote: > Oleksandr Grytsov writes ("[PATCH v2 2/3] libxl: rename VKB backend type "linux" to "pv""): > > From: Oleksandr Grytsov <oleksandr_grytsov@epam.com> > > > > There are two kind of VKB backends: QEMU and user space PV backend. > > For PV backend "linux" enum is used but this name is confused. Rename > > "linux" enum to "pv" as it better matches user space PV backend. > > > > Signed-off-by: Oleksandr Grytsov <oleksandr_grytsov@epam.com> > > Requested-by: Ian Jackson <ian.jackson@eu.citrix.com> > Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> The LINUX type was introduced back in 2018. This patch should have provided at least a #define ...LINUX ...PV in libxl.h for backward compatibility purpose. Wei. > > Thanks. > > Ian.
Wei Liu writes ("Re: [PATCH v2 2/3] libxl: rename VKB backend type "linux" to "pv""): > The LINUX type was introduced back in 2018. Oh. Yes. I used a wrong git-describe rune to try to find out where it had been introduced. The answer in fact is that it was in 4.12.0-rc1. Thanks for pointing this out. Thanks also for the 2nd pair of eyes on [PATCH v2 3/3] libxl: make default path to add/remove all PV devices > This patch should have provided at least a > #define ...LINUX ...PV > in libxl.h for backward compatibility purpose. Under the circumstances, given that I suggested the rename during the 4.13 freeze, and the (IMO wrong) name was shipped in 4.12, it seems that we should drop this patch for 4.13. This is something that perhaps we should think about for the future but if it's been released already the cost of messing about with the name is sharply larger, and it may not be worth it at all. Sorry for messing you about more, Oleksandr. The other two patches 1/ and 3/ apply and work just fine without this middle one, so I don't think we need a resend. I'm still hoping for a 2nd pair of eyes on [PATCH v2 1/3] libxl: introduce new backend type VINPUT and a release ack for both 1/3 and 3/3. Ian.
diff --git a/docs/man/xl.cfg.5.pod.in b/docs/man/xl.cfg.5.pod.in index 245d3f9472..37bdc595d3 100644 --- a/docs/man/xl.cfg.5.pod.in +++ b/docs/man/xl.cfg.5.pod.in @@ -1562,8 +1562,8 @@ Specifies the backend domain name or id. =item B<backend-type=type> -Specifies the backend type: qemu - for QEMU backend or linux - for Linux PV -domain. +Specifies the backend type: qemu - for QEMU backend or pv - for PV +backend. =item B<feature-disable-keyboard=BOOLEAN> diff --git a/tools/libxl/libxl_types.idl b/tools/libxl/libxl_types.idl index 0546d7865a..751dad8870 100644 --- a/tools/libxl/libxl_types.idl +++ b/tools/libxl/libxl_types.idl @@ -260,7 +260,7 @@ libxl_vuart_type = Enumeration("vuart_type", [ libxl_vkb_backend = Enumeration("vkb_backend", [ (0, "UNKNOWN"), (1, "QEMU"), - (2, "LINUX") + (2, "PV") ]) libxl_passthrough = Enumeration("passthrough", [ diff --git a/tools/libxl/libxl_vkb.c b/tools/libxl/libxl_vkb.c index 4c44a813c1..5f018f55b7 100644 --- a/tools/libxl/libxl_vkb.c +++ b/tools/libxl/libxl_vkb.c @@ -113,7 +113,7 @@ static int libxl__vkb_from_xenstore(libxl__gc *gc, const char *libxl_path, if (rc) goto out; vkb->backend_type = dev.backend_kind == LIBXL__DEVICE_KIND_VINPUT ? - LIBXL_VKB_BACKEND_LINUX : LIBXL_VKB_BACKEND_QEMU; + LIBXL_VKB_BACKEND_PV : LIBXL_VKB_BACKEND_QEMU; vkb->unique_id = xs_read(CTX->xsh, XBT_NULL, GCSPRINTF("%s/"XENKBD_FIELD_UNIQUE_ID, be_path), NULL); @@ -219,7 +219,7 @@ static int libxl__device_from_vkb(libxl__gc *gc, uint32_t domid, { device->backend_devid = type->devid; device->backend_domid = type->backend_domid; - device->backend_kind = type->backend_type == LIBXL_VKB_BACKEND_LINUX ? + device->backend_kind = type->backend_type == LIBXL_VKB_BACKEND_PV ? LIBXL__DEVICE_KIND_VINPUT : LIBXL__DEVICE_KIND_VKBD; device->devid = type->devid; device->domid = domid;