diff mbox series

xen: use helper macro __ATTR_RW

Message ID 20220222111222.56877-1-linmiaohe@huawei.com (mailing list archive)
State New, archived
Headers show
Series xen: use helper macro __ATTR_RW | expand

Commit Message

Miaohe Lin Feb. 22, 2022, 11:12 a.m. UTC
Use helper macro __ATTR_RW to define hyp_sysfs_attr to make code more
clear. Minor readability improvement.

Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>
---
 drivers/xen/sys-hypervisor.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Jürgen Groß Feb. 22, 2022, noon UTC | #1
On 22.02.22 12:12, Miaohe Lin wrote:
> Use helper macro __ATTR_RW to define hyp_sysfs_attr to make code more
> clear. Minor readability improvement.
> 
> Signed-off-by: Miaohe Lin <linmiaohe@huawei.com>

Reviewed-by: Juergen Gross <jgross@suse.com>


Juergen
diff mbox series

Patch

diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
index feb1d16252e7..5e842c88a13e 100644
--- a/drivers/xen/sys-hypervisor.c
+++ b/drivers/xen/sys-hypervisor.c
@@ -25,8 +25,7 @@ 
 static struct hyp_sysfs_attr  _name##_attr = __ATTR_RO(_name)
 
 #define HYPERVISOR_ATTR_RW(_name) \
-static struct hyp_sysfs_attr _name##_attr = \
-	__ATTR(_name, 0644, _name##_show, _name##_store)
+static struct hyp_sysfs_attr _name##_attr = __ATTR_RW(_name)
 
 struct hyp_sysfs_attr {
 	struct attribute attr;