@@ -586,7 +586,7 @@ struct ucode_buf {
char buffer[];
};
-static long cf_check microcode_update_helper(void *data)
+static long cf_check ucode_update_hcall_cont(void *data)
{
int ret;
struct ucode_buf *buffer = data;
@@ -722,8 +722,8 @@ static long cf_check microcode_update_helper(void *data)
return ret;
}
-int microcode_update(XEN_GUEST_HANDLE(const_void) buf,
- unsigned long len, unsigned int flags)
+int ucode_update_hcall(XEN_GUEST_HANDLE(const_void) buf,
+ unsigned long len, unsigned int flags)
{
int ret;
struct ucode_buf *buffer;
@@ -748,11 +748,11 @@ int microcode_update(XEN_GUEST_HANDLE(const_void) buf,
buffer->flags = flags;
/*
- * Always queue microcode_update_helper() on CPU0. Most of the logic
+ * Always queue ucode_update_hcall_cont() on CPU0. Most of the logic
* won't care, but the update of the Raw CPU policy wants to (re)run on
* the BSP.
*/
- return continue_hypercall_on_cpu(0, microcode_update_helper, buffer);
+ return continue_hypercall_on_cpu(0, ucode_update_hcall_cont, buffer);
}
static int __init cf_check microcode_init(void)
@@ -22,8 +22,8 @@ struct cpu_signature {
DECLARE_PER_CPU(struct cpu_signature, cpu_sig);
void microcode_set_module(unsigned int idx);
-int microcode_update(XEN_GUEST_HANDLE(const_void) buf,
- unsigned long len, unsigned int flags);
+int ucode_update_hcall(XEN_GUEST_HANDLE(const_void) buf,
+ unsigned long len, unsigned int flags);
int microcode_update_one(void);
struct boot_info;
@@ -313,7 +313,7 @@ ret_t do_platform_op(
guest_from_compat_handle(data, op->u.microcode.data);
- ret = microcode_update(data, op->u.microcode.length, 0);
+ ret = ucode_update_hcall(data, op->u.microcode.length, 0);
break;
}
@@ -323,8 +323,8 @@ ret_t do_platform_op(
guest_from_compat_handle(data, op->u.microcode2.data);
- ret = microcode_update(data, op->u.microcode2.length,
- op->u.microcode2.flags);
+ ret = ucode_update_hcall(data, op->u.microcode2.length,
+ op->u.microcode2.flags);
break;
}
microcode_update{,_helper}() are overly generic names in a file that has multiple update routines and helper functions contexts. Rename microcode_update() to ucode_update_hcall() so it explicitly identifies itself as hypercall context, and rename microcode_update_helper() to ucode_update_hcall_cont() to make it clear it is in continuation context. No functional change. Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com> --- CC: Jan Beulich <JBeulich@suse.com> CC: Roger Pau Monné <roger.pau@citrix.com> --- xen/arch/x86/cpu/microcode/core.c | 10 +++++----- xen/arch/x86/include/asm/microcode.h | 4 ++-- xen/arch/x86/platform_hypercall.c | 6 +++--- 3 files changed, 10 insertions(+), 10 deletions(-)