@@ -633,8 +633,8 @@ int hvm_domain_initialise(struct domain *d,
/* Set the number of GSIs */
hvm_domain_irq(d)->nr_gsis = nr_gsis;
- BUILD_BUG_ON(NR_HVM_DOMU_IRQS < NR_ISAIRQS);
- ASSERT(hvm_domain_irq(d)->nr_gsis >= NR_ISAIRQS);
+ BUILD_BUG_ON(NR_HVM_DOMU_IRQS < NR_ISA_IRQS);
+ ASSERT(hvm_domain_irq(d)->nr_gsis >= NR_ISA_IRQS);
/* need link to containing domain */
d->arch.hvm.pl_time->domain = d;
@@ -491,7 +491,7 @@ void create_periodic_time(
uint64_t period, uint8_t irq, time_cb *cb, void *data, bool level)
{
if ( !pt->source ||
- (irq >= NR_ISAIRQS && pt->source == PTSRC_isa) ||
+ (irq >= NR_ISA_IRQS && pt->source == PTSRC_isa) ||
(level && period) ||
(pt->source == PTSRC_ioapic ? irq >= hvm_domain_irq(v->domain)->nr_gsis
: level) )
@@ -134,7 +134,7 @@ struct hvm_girq_dpci_mapping {
uint8_t machine_gsi;
};
-#define NR_ISAIRQS 16
+#define NR_ISA_IRQS 16
#define NR_LINK 4
#define NR_HVM_DOMU_IRQS ARRAY_SIZE(((struct hvm_hw_vioapic *)NULL)->redirtbl)
@@ -143,7 +143,7 @@ struct hvm_irq_dpci {
/* Guest IRQ to guest device/intx mapping. */
struct list_head girq[NR_HVM_DOMU_IRQS];
/* Record of mapped ISA IRQs */
- DECLARE_BITMAP(isairq_map, NR_ISAIRQS);
+ DECLARE_BITMAP(isairq_map, NR_ISA_IRQS);
/* Record of mapped Links */
uint8_t link_cnt[NR_LINK];
};
@@ -198,7 +198,7 @@ ret_t do_physdev_op(int cmd, XEN_GUEST_HANDLE_PARAM(void) arg)
/* if this is a level irq and count > 0, send another
* notification */
- if ( gsi >= NR_ISAIRQS /* ISA irqs are edge triggered */
+ if ( gsi >= NR_ISA_IRQS /* ISA irqs are edge triggered */
&& hvm_irq->gsi_assert_count[gsi] )
send_guest_pirq(currd, pirq);
}
@@ -958,7 +958,7 @@ static void hvm_dpci_isairq_eoi(struct domain *d, unsigned int isairq)
{
const struct hvm_irq_dpci *dpci = NULL;
- ASSERT(isairq < NR_ISAIRQS);
+ ASSERT(isairq < NR_ISA_IRQS);
if ( !is_iommu_enabled(d) )
return;
@@ -991,7 +991,7 @@ void hvm_dpci_eoi(struct domain *d, unsigned int guest_gsi)
goto unlock;
}
- if ( guest_gsi < NR_ISAIRQS )
+ if ( guest_gsi < NR_ISA_IRQS )
{
hvm_dpci_isairq_eoi(d, guest_gsi);
return;
Rename NR_ISAIRQS to NR_ISA_IRQS to enhance readability. No functional changes. Signed-off-by: Denis Mukhin <dmukhin@ford.com> --- xen/arch/x86/hvm/hvm.c | 4 ++-- xen/arch/x86/hvm/vpt.c | 2 +- xen/arch/x86/include/asm/hvm/irq.h | 4 ++-- xen/arch/x86/physdev.c | 2 +- xen/drivers/passthrough/x86/hvm.c | 4 ++-- 5 files changed, 8 insertions(+), 8 deletions(-)