Message ID | 20200415064523.2244712-10-ira.weiny@intel.com (mailing list archive) |
---|---|
State | Superseded, archived |
Headers | show |
Series | Enable per-file/per-directory DAX operations V8 | expand |
On Tue 14-04-20 23:45:21, ira.weiny@intel.com wrote: > From: Ira Weiny <ira.weiny@intel.com> > > DCACHE_DONTCACHE indicates a dentry should not be cached on final > dput(). > > Also add a helper function which will flag I_DONTCACHE as well ad > DCACHE_DONTCACHE on all dentries point to a specified inode. I think this sentence needs more work :). Like: Also add a helper function which will mark the inode with I_DONTCACHE flag and also mark all dentries pointing to a specified inode as DCACHE_DONTCACHE. > > Signed-off-by: Ira Weiny <ira.weiny@intel.com> > > --- > Changes from V7: > new patch > --- > fs/dcache.c | 4 ++++ > fs/inode.c | 15 +++++++++++++++ > include/linux/dcache.h | 2 ++ > include/linux/fs.h | 1 + > 4 files changed, 22 insertions(+) ... > diff --git a/fs/inode.c b/fs/inode.c > index 93d9252a00ab..b8b1917a324e 100644 > --- a/fs/inode.c > +++ b/fs/inode.c > @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode) > } > EXPORT_SYMBOL(generic_delete_inode); > > +void flag_inode_dontcache(struct inode *inode) mark_inode_dontcache? > +{ > + struct dentry *dent; This is really nitpicking but dentry variables are usually called 'de' or 'dentry' :) > + > + rcu_read_lock(); I don't think this list is safe to traverse under RCU. E.g. dentry_unlink_inode() does hlist_del_init(&dentry->d_u.d_alias). Usually, we traverse this list under inode->i_lock protection AFAICS. Honza > + hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) { > + spin_lock(&dent->d_lock); > + dent->d_flags |= DCACHE_DONTCACHE; > + spin_unlock(&dent->d_lock); > + } > + rcu_read_unlock(); > + inode->i_state |= I_DONTCACHE; > +} > +EXPORT_SYMBOL(flag_inode_dontcache); > + > /* > * Called when we're dropping the last reference > * to an inode.
On Wed, Apr 15, 2020 at 11:01:53AM +0200, Jan Kara wrote: > On Tue 14-04-20 23:45:21, ira.weiny@intel.com wrote: > > From: Ira Weiny <ira.weiny@intel.com> > > > > DCACHE_DONTCACHE indicates a dentry should not be cached on final > > dput(). > > > > Also add a helper function which will flag I_DONTCACHE as well ad > > DCACHE_DONTCACHE on all dentries point to a specified inode. > > I think this sentence needs more work :). Like: Also add a helper function > which will mark the inode with I_DONTCACHE flag and also mark all dentries > pointing to a specified inode as DCACHE_DONTCACHE. > > > > > Signed-off-by: Ira Weiny <ira.weiny@intel.com> > > > > --- > > Changes from V7: > > new patch > > --- > > fs/dcache.c | 4 ++++ > > fs/inode.c | 15 +++++++++++++++ > > include/linux/dcache.h | 2 ++ > > include/linux/fs.h | 1 + > > 4 files changed, 22 insertions(+) > > ... > > > diff --git a/fs/inode.c b/fs/inode.c > > index 93d9252a00ab..b8b1917a324e 100644 > > --- a/fs/inode.c > > +++ b/fs/inode.c > > @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode) > > } > > EXPORT_SYMBOL(generic_delete_inode); > > > > +void flag_inode_dontcache(struct inode *inode) > > mark_inode_dontcache? That works. > > > +{ > > + struct dentry *dent; > > This is really nitpicking but dentry variables are usually called 'de' or > 'dentry' :) Easy change. done. > > > + > > + rcu_read_lock(); > > I don't think this list is safe to traverse under RCU. E.g. > dentry_unlink_inode() does hlist_del_init(&dentry->d_u.d_alias). Usually, > we traverse this list under inode->i_lock protection AFAICS. Ah... not sure where I got that. I thought I found this locked with rcu somewhere but I obviously got confused. And I did not even use the rcu version of the list iterator... :-( I'll clean it up, thanks for the review, Ira > > Honza > > > + hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) { > > + spin_lock(&dent->d_lock); > > + dent->d_flags |= DCACHE_DONTCACHE; > > + spin_unlock(&dent->d_lock); > > + } > > + rcu_read_unlock(); > > + inode->i_state |= I_DONTCACHE; > > +} > > +EXPORT_SYMBOL(flag_inode_dontcache); > > + > > /* > > * Called when we're dropping the last reference > > * to an inode. > -- > Jan Kara <jack@suse.com> > SUSE Labs, CR
diff --git a/fs/dcache.c b/fs/dcache.c index b280e07e162b..0030fabab2c4 100644 --- a/fs/dcache.c +++ b/fs/dcache.c @@ -647,6 +647,10 @@ static inline bool retain_dentry(struct dentry *dentry) if (dentry->d_op->d_delete(dentry)) return false; } + + if (unlikely(dentry->d_flags & DCACHE_DONTCACHE)) + return false; + /* retain; LRU fodder */ dentry->d_lockref.count--; if (unlikely(!(dentry->d_flags & DCACHE_LRU_LIST))) diff --git a/fs/inode.c b/fs/inode.c index 93d9252a00ab..b8b1917a324e 100644 --- a/fs/inode.c +++ b/fs/inode.c @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode) } EXPORT_SYMBOL(generic_delete_inode); +void flag_inode_dontcache(struct inode *inode) +{ + struct dentry *dent; + + rcu_read_lock(); + hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) { + spin_lock(&dent->d_lock); + dent->d_flags |= DCACHE_DONTCACHE; + spin_unlock(&dent->d_lock); + } + rcu_read_unlock(); + inode->i_state |= I_DONTCACHE; +} +EXPORT_SYMBOL(flag_inode_dontcache); + /* * Called when we're dropping the last reference * to an inode. diff --git a/include/linux/dcache.h b/include/linux/dcache.h index c1488cc84fd9..56b1482d9223 100644 --- a/include/linux/dcache.h +++ b/include/linux/dcache.h @@ -177,6 +177,8 @@ struct dentry_operations { #define DCACHE_REFERENCED 0x00000040 /* Recently used, don't discard. */ +#define DCACHE_DONTCACHE 0x00000080 /* don't cache on final dput() */ + #define DCACHE_CANT_MOUNT 0x00000100 #define DCACHE_GENOCIDE 0x00000200 #define DCACHE_SHRINK_LIST 0x00000400 diff --git a/include/linux/fs.h b/include/linux/fs.h index e2db71d150c3..f2916c99616a 100644 --- a/include/linux/fs.h +++ b/include/linux/fs.h @@ -3048,6 +3048,7 @@ static inline int generic_drop_inode(struct inode *inode) return !inode->i_nlink || inode_unhashed(inode) || (inode->i_state & I_DONTCACHE); } +extern void flag_inode_dontcache(struct inode *inode); extern struct inode *ilookup5_nowait(struct super_block *sb, unsigned long hashval, int (*test)(struct inode *, void *),